US Cloud Provider Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved
Posted Jun 30, 2023 - 11:48 CDT
Investigating
We are investigating an issue that impacts the availability of some AWS EC2 instances in the us-east-2 region.
Posted Jun 30, 2023 - 10:42 CDT
This incident affected: North America Data Center.