Multiple Data Center Locations Partial Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 15:15 CDT
Investigating
We are currently investigating a partial outage at multiple data center locations.
Posted Oct 06, 2021 - 14:20 CDT
This incident affected: North America Data Center and Asia Pacific Data Center.