Critical Patch Deployment

Incident Report for Flex Rental Solutions

Resolved

The patch has been deployed successfully.
Posted Feb 19, 2025 - 16:16 CST

Monitoring

We are deploying a critical patch, some brief periods of downtime are expected.
Posted Feb 19, 2025 - 15:38 CST
This incident affected: Flex Software.