Silicon Valley Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 09:02 CDT
Monitoring
We have identified an outage at one of our Silicon Valley data centers.
Posted Apr 27, 2021 - 07:34 CDT
This incident affected: North America Data Center.