Restarting all USA servers
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Oct 20, 2016 - 03:31 CDT
Update
Downtime should only be about 60 minutes
Posted Oct 20, 2016 - 01:55 CDT
Investigating
We are currently investigating this issue.
Posted Oct 20, 2016 - 01:54 CDT