Silicon Valley Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 13:19 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2021 - 13:02 CDT
Investigating
We are currently experiencing a partial outage in one of our Silicon Valley data centers, and are working to restore service as soon as possible.
Posted Jul 13, 2021 - 12:30 CDT
This incident affected: North America Data Center.