Server Maintenance for Europe and Africa Data Center
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Apr 18, 2018 - 20:53 CDT
Monitoring
Offline for approximately 1 hour.
Posted Apr 18, 2018 - 20:18 CDT