Dallas Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 10:33 CST
Investigating
One of our servers at a Dallas data center is experiencing an outage.
Posted Mar 12, 2021 - 09:26 CST
This incident affected: North America Data Center.