Dallas Server Restart
Incident Report for Flex Rental Solutions
Resolved
Service restored.
Posted Jan 18, 2018 - 11:13 CST
Monitoring
Dallas Server has been restarted. We are monitoring the server and will update when all instances are back online. We apologize for the inconvenience.
Posted Jan 18, 2018 - 10:28 CST