Chicago server maintenance
Incident Report for Flex Rental Solutions
Resolved
Maintenance complete. Please allow up to an hour for services to be back online.
Posted Nov 04, 2017 - 22:20 CDT
Monitoring
Server maintenance in process.
Posted Nov 04, 2017 - 22:08 CDT
Investigating
Chicago servers will be down for up to an hour for maintenance.
Posted Nov 04, 2017 - 22:05 CDT