Amsterdam Datacenter Maintenance
Incident Report for Flex Rental Solutions
Resolved
All Amsterdam Servers are now online and fully operational following successful maintenance.
Posted Sep 13, 2016 - 16:54 CDT
Investigating
The Flex Amsterdam Datacenter is currently being rebooted as part of scheduled maintenance.
Posted Sep 13, 2016 - 15:57 CDT