Dallas Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
The datacenter provider has resolved the issue with our Dallas server. Services should be returned to normal at this time. We apologize for the inconvenience.
Posted Jan 04, 2021 - 15:44 CST
Investigating
We are currently investigating an outage at one of our Dallas data centers.
Posted Jan 04, 2021 - 09:20 CST
This incident affected: North America Data Center.