Server Maintenance (Asia Region)
Incident Report for Flex Rental Solutions
Resolved
Maintenance completed
Posted Nov 30, 2016 - 09:42 CST
Monitoring
Routine Server Maintenance. Offline about 1 hour.
Posted Nov 30, 2016 - 08:26 CST