Dallas Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 13:48 CDT
Investigating
We are seeing a potential outage at two of our data center locations.
Posted Sep 29, 2020 - 11:13 CDT
This incident affected: North America Data Center.