North America Datacenter Outage
Incident Report for Flex Rental Solutions
Resolved
All services have returned to normal.
Posted Nov 21, 2020 - 12:45 CST
Monitoring
The server has been brought back online. We are monitoring the restart activity.
Posted Nov 21, 2020 - 12:13 CST
Identified
One of our servers hosting North American customers has gone offline. We are working with the service provider to bring things back. We apologize for the disruption in service.
Posted Nov 21, 2020 - 11:30 CST
This incident affected: North America Data Center.