Sydney Datacenter
Incident Report for Flex Rental Solutions
Resolved
Maintenance has been completed and all operations are functional.
Posted Sep 20, 2017 - 12:24 CDT
Identified
The Sydney datacenter is undergoing scheduled maintenance.
Posted Sep 20, 2017 - 11:07 CDT