Flex Datacenter Outage North America
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 15:33 CST
Investigating
There is an issue with AWS which is impacting network connectivity.
Posted Dec 05, 2022 - 15:32 CST
This incident affected: North America Data Center.