Isolated Server Issue
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 15:42 CDT
Investigating
We are currently investigating an issue on one of our servers at a Chicago data center.
Posted Sep 16, 2020 - 12:52 CDT