Server Maintenance for Asia-Pacific Data Center
Incident Report for Flex Rental Solutions
Resolved
Maintenance has been completed and all services have been restored.
Posted Apr 18, 2018 - 13:58 CDT
Monitoring
Offline approximately 1 hour.
Posted Apr 18, 2018 - 12:36 CDT