Flex Datacenter Maintenance
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Mar 29, 2019 - 01:22 CDT
Monitoring
Flex Support is performing scheduled maintenance on one of our North American servers. Downtime is expected to span multiple hours.
Posted Mar 28, 2019 - 22:51 CDT
This incident affected: North America Data Center.