Chicago Datacenter Maintenance.
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Mar 20, 2017 - 07:21 CDT
Monitoring
A server in our Chicago datacenter is undergoing extended maintenance. Estimated downtime is 1AM EDT until 7AM EDT.
Posted Mar 19, 2017 - 23:56 CDT