Atlanta Data Center Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Oct 23, 2020 - 15:04 CDT
Update
We are continuing to monitor for any further issues.
Posted Oct 23, 2020 - 14:27 CDT
Monitoring
We have identified a partial outage at one of our data centers in Atlanta, GA.
Posted Oct 23, 2020 - 12:01 CDT
This incident affected: North America Data Center.