Scheduled Server Maintenance

Incident Report for Flex Rental Solutions

Resolved

This incident has been resolved.
Posted May 20, 2019 - 01:21 CDT

Monitoring

We are currently performing scheduled maintenance on our North America Data Center. This should only affect a limited number of customers.
Posted May 19, 2019 - 23:13 CDT
This incident affected: North America Data Center.