Flex Datacenter Maintenance
Incident Report for Flex Rental Solutions
Resolved
Maintenance complete. All Flex Sites should be back online.
Posted May 05, 2019 - 10:22 CDT
Monitoring
Flex Support is performing scheduled maintenance from approximately 7am - 12pm Eastern time. Approximately 10% of US customers will be down during this time period.
Posted May 05, 2019 - 05:37 CDT
This incident affected: North America Data Center.