Chicago Data Center Partial Outage
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 14:00 CDT
Investigating
One of our cloud hosting providers in Chicago is reporting a partial outage.
Posted Oct 26, 2020 - 10:14 CDT
This incident affected: North America Data Center.