Scheduled Server Maintenance (USA Servers)
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted Dec 01, 2016 - 04:18 CST
Investigating
Initiating USA server maintenance. Offline time approximately 1 hour.
Posted Dec 01, 2016 - 02:03 CST