Amsterdam Datacenter Maintenance
Incident Report for Flex Rental Solutions
Resolved
Amsterdam datacenter maintenance is complete.
Posted Mar 27, 2017 - 15:58 CDT
Monitoring
The Amsterdam Datacenter is currently undergoing scheduled maintenance. Estimated downtime is 1 to 2 hours.
Posted Mar 27, 2017 - 15:00 CDT