Server Maintenance
Incident Report for Flex Rental Solutions
Resolved
This incident has been resolved.
Posted May 21, 2019 - 00:16 CDT
Monitoring
We are currently performing scheduled maintenance. This will affect a limited number of customers.
Posted May 20, 2019 - 23:04 CDT
This incident affected: North America Data Center.