Europe Datacenter Maintenance
Incident Report for Flex Rental Solutions
Resolved
All services are fully operational.
Posted Jun 13, 2017 - 20:06 CDT
Monitoring
Maintenance has been completed on our Europe Datacenter, and all services are coming back online. We will be monitoring the services to make sure all systems are operational before this is resolved.
Posted Jun 13, 2017 - 19:58 CDT
Identified
Flex is performing scheduled maintenance on our Europe Datacenter. Down time is estimated to be an hour long.
Posted Jun 13, 2017 - 19:01 CDT