North America Datacenter
Incident Report for Flex Rental Solutions
Resolved
Maintenance is completed and all systems are operational.
Posted Jun 13, 2017 - 01:30 CDT
Monitoring
Maintenance is almost completed, will monitor to make sure all systems are operational.
Posted Jun 13, 2017 - 01:20 CDT
Identified
Flex Support is performing datacenter maintenance at this time. Estimated downtime is 1 hour.
Posted Jun 13, 2017 - 00:24 CDT